Category: технологии

Category was added automatically. Read all entries about "технологии".

Мои достижения в 2014

Я закончил летнюю физматшколу МФТИ за 6 класс, закончил заочную физматшколу МИФИ за 6 класс, решил много задач за шестой класс из учебника физматшколы МГУ. Впервые участвовал в олимпиаде МФТИ, набрал 26 баллов из 42. Я из 6 задач решил 3 полностью, 2 только ответ записал, 1 я не успел сделать.

Я ходил на занятия по робототехнике, там написал много программ, спаял 2 печатных платы и сделал робота-тележку на Ардуино.

Впервые я побывал на Чёрном море. Ежедневно купался по 3 часа.

история одного решения

Я откопировал решение из прошлой задачи и добавил свою новую программу. И не было ничего трудного.

использовать Робот

алг Копировать прямоугольник
 дано | Робот в левом верхнем углу закрашенного прямоугольника
 надо | Робот рисует такой же прямоугольник справа от исходного 
| на расстоянии одной клетки от него и возвращается в начальную клетку
| Используйте алгоритм определения размеров прямоугольника из предыдущей задачи
| и алгоритм рисования прямоугольника из предыдущего листка
 нач
 цел в
 цел дл
 в :=0
 дл :=0
 Размер прямоугольника (в,дл)
 нц дл+1 раз
  вправо
 кц
 нц дл раз
  нц в раз
   закрасить
   вниз
  кц
  нц в раз
   вверх
  кц
  вправо
 кц
 нц дл*2+1 раз
  влево
 кц
кон
алг Размер прямоугольника (рез цел высота, длина)
нач
 высота :=0
 длина :=0
 нц пока клетка закрашена
  вправо
  длина :=длина+1
 кц
 влево
 нц пока клетка закрашена
  вниз
  высота :=высота+1
 кц
 нц длина-1 раз
  влево
 кц
 нц высота раз
  вверх
 кц
кон