aalev (aalev) wrote,
aalev
aalev

Categories:

история одного решения

Я откопировал решение из прошлой задачи и добавил свою новую программу. И не было ничего трудного.

использовать Робот

алг Копировать прямоугольник
 дано | Робот в левом верхнем углу закрашенного прямоугольника
 надо | Робот рисует такой же прямоугольник справа от исходного 
| на расстоянии одной клетки от него и возвращается в начальную клетку
| Используйте алгоритм определения размеров прямоугольника из предыдущей задачи
| и алгоритм рисования прямоугольника из предыдущего листка
 нач
 цел в
 цел дл
 в :=0
 дл :=0
 Размер прямоугольника (в,дл)
 нц дл+1 раз
  вправо
 кц
 нц дл раз
  нц в раз
   закрасить
   вниз
  кц
  нц в раз
   вверх
  кц
  вправо
 кц
 нц дл*2+1 раз
  влево
 кц
кон
алг Размер прямоугольника (рез цел высота, длина)
нач
 высота :=0
 длина :=0
 нц пока клетка закрашена
  вправо
  длина :=длина+1
 кц
 влево
 нц пока клетка закрашена
  вниз
  высота :=высота+1
 кц
 нц длина-1 раз
  влево
 кц
 нц высота раз
  вверх
 кц
кон
Subscribe

  • Мои достижения в 2014

    Я закончил летнюю физматшколу МФТИ за 6 класс, закончил заочную физматшколу МИФИ за 6 класс, решил много задач за шестой класс из учебника…

  • Город будущего.

    В городе будущего все люди станут учёными и очень умными. Умные женщины станут выбирать себе мужчин не по силе, а по уму потому, что главное оружие -…

  • Мои искуственные вирусы и бактерии.

    Я хотел в будущем создать мои искуственные бактерии и вирусы. Вирусы будут прицепляться к клеткам и улучшать клетки одну за другой и как все вирусы -…

  • Post a new comment

    Error

    Anonymous comments are disabled in this journal

    default userpic

    Your IP address will be recorded 

  • 0 comments